关于升级最新版本Sugar连接SQL提示TSL问题? 返回

SqlSugar
5 231

升级到最新版本后,连接sql会提示"The negotiated TLS 1.0 is an insecure protocol and is supported for backward compatibility only. The recommended protocol version is TLS 1.2 and later." ,,,,,,,这种情况是不是需要开启数据库的TLS支持.


热忱回答5

  • fate sta fate sta VIP0
    1个月前

    什么数据库

    0 回复
  • fate sta fate sta VIP0
    1个月前

    目前只有SqlServer和Oracle驱动更新过

    0 回复
  • @fate sta: sql server

    0 回复
  • fate sta fate sta VIP0
    1个月前

    Security Warning: The negotiated TLS 1.0 is an insecure protocol and is supported for backward compatibility only. The recommended protocol version is TLS 1.2 and later.

    我这里是使用的是sqlserver2014数据库, 打上sqlserver 2014 SP3补丁即可


    Timeout expired. The timeout period elapsed prior to obtaining a connection from the pool. This may have occurred because all pooled connections were in use and max pool size was reached.”

    Server=rd5-hgh;uid=sa;pwd=xxxx;database=humanresource;Max Pool Size=200;connection timeout=600


    加上 connection timeout


    这是网上的方案

     

    0 回复
  • @fate sta:我连接SQL2016也同样会提示这个问题,,网上我也查阅过,说2016默认支持TLS 1.2  

    我打上这个补丁试试吧,,我把NET也升级到了6.0  在IIS还好,直接无视这个问题,,在linux上就不行了。


    0 回复