请尽快支持 net 6 返回

SqlSugar
12 167

今天想使用C# 10 的语法糖 , 升级了项目到 net6 , 但是发现SqlSugar , 目前只能支持框架到  3.1  , 以及 netstandar 2.1 ,请尽快升级 . 

热忱回答12

  • NU1202: Package SqlSugarCore 5.0.4.2 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.4.2 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.4.2 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.4.2 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.4.2 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.4.2 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.4.2 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.4.2 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.4.2 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.4.2 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.4.2 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.4.2 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.4.2 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.4.2 supports: netstandard2.1 (.NETStandard,Version=v2.1)


    0 回复
  • sqlsugarcore版本升高一点

    0 回复
  • 目前发现 net 6 , 貌似不能直接支持 netstandar 2.1

    0 回复
  • 你可以新建一个控制台测试暂时没有其它.NET 6用户遇到问题

    0 回复
  • NU1202: Package SqlSugarCore 5.0.5.1 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.5.1 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.5.1 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.5.1 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.5.1 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.5.1 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.5.1 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.5.1 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.5.1 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.5.1 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.5.1 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.5.1 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.5.1 is not compatible with net60 (.NETFramework,Version=v6.0). Package SqlSugarCore 5.0.5.1 supports: netstandard2.1 (.NETStandard,Version=v2.1)
    NU1202: Package SqlSugarCore 5.0.5.1 is not compatible with net60 (.NETFramework,Version=v6.0) / win7-x86. Package SqlSugarCore 5.0.5.1 supports: netstandard2.1 (.NETStandard,Version=v2.1)


    0 回复
  • @fate sta:这个直接运行是可以的 , 但是nuget检测有警告 , 是不是 依赖项需要更新一下 ? 

    0 回复
  • @fate staimage.png

    image.png

    我这里配置了CI nuget 强制检测兼容问题 ,为了保证服务器环境的稳定

    0 回复
  • @fate sta:用是能用 , 但是nuget里面会有一个感叹号啊 ! 正式环境是不允许有兼容问题的。大哥有没有兼容计划 , 麻烦告知一下 。

    0 回复
  • @Aaron 傲:我在问问其他用户,没有反馈过你这种问题

    0 回复
  • JD6S[GGRFLV_O229%H{ZPDO.png

    0 回复
  • 其他用户反馈没问题

    0 回复
  • 你看看是不是什么类库冲突了

    0 回复